Ask a Mechanic.

Ask a Mechanic a Question

Below are questions submitted to approved mechanics for advice and feedback. You must be a registered user to post a question. If you would like to become an approved mechanic an answer questions, please shoot an email to info@flymechanic.com.

Search By Keyword

Moisture Issue

Not Answered

I have a 2002 Vans RV-6 and recently both my steam gauge altimeter and the adjacent steam gauge vertical speed indicator quit working. The inside of the glass plate on the front of both of these gauges had some sort of moisture - it looked like really small particles of water. All of my other gauges are just fine. These instruments have been fine for years. Any idea what could be causing this???

View Question
Asked by JBuckholz Nov. 18, 2015

STEC 50 autopilot

Not Answered

My altitude hold sometimes does not function. This is a rare event. Now working. I am reluctant to have an avionics shop troubleshoot a rare intermittent problem. I checked all electrical connections and the static lines to the pressure transducer. No leaks or obstruction (independent static system). Do I have a faulty pressure transducer? Very pricey to replace, especially since the altitude hold now works.

View Question
Asked by meldr Aug. 13, 2015

Yaw dampener keeps turning off

Not Answered

I have a 1978 Piper Navajo Chieftain PA-31-350. In cruise my yaw dampener keeps turning off and popping the circuit breaker. It will blow the breaker with in 2-4 seconds after it is turned on. Any thoughts?

View Question
Asked by navajodriver April 29, 2014

Trim tab off??

Answered

My plane is flying just slightly to the right when I trim it out. I only have elevator trim, so my left foot get's tired on long flights. What's the fix?

View Question
Asked by homebuiltflyer Dec. 11, 2012

EGT high in cruise

Answered

I am having trouble with my EGT in cruise. When I approach 75% power I am too close to redline for comfort. What would cause this?

View Question
Asked by crazy_ace Dec. 11, 2012